const regex = /label\W+(?:\w+\W+){1,60}?(?:.){0,}?(\<TAG1\>|\<TAG2\>)(?:.){0,}?\W+(?:\w+\W+){1,60}(?:.){0,}?(\<TAG2\>|\<TAG1\>)(?:.){0,}?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('label\\W+(?:\\w+\\W+){1,60}?(?:.){0,}?(\\<TAG1\\>|\\<TAG2\\>)(?:.){0,}?\\W+(?:\\w+\\W+){1,60}(?:.){0,}?(\\<TAG2\\>|\\<TAG1\\>)(?:.){0,}?', '')
const str = `before label bla bla bla aaaa<TAG1>bbbb bla bla bla bla abcd<TAG2>efgh after`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}