re = /^commits:[ ]{0,}(.*)/im
str = 'commits:56af25a...d3fead4
Commits: [56af25a...d3fead4](https://github.com/Glimpse/Semantic-Release-Notes/compare/56af25a...d3fead4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end