const regex = /[^a-zA-Z0-9&\'\" +]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9&\\\'\\" +]', 'g')
const str = `Integrated Eligibility System, Enrollment, Case Management System, EECM Solution Design, Medical Assistance Program, dig
ital, client self-service and delivery channel en
hancements, data sharing, reporting, analytics Technology`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);