import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) #ignora isso é para aceitar multi linha e comentario\n\n"
+ "^ # inicio\n"
+ "(?=.*?[a-z]) # procura por caracteres `a` atá `z` pelo menos 1\n"
+ "(?=(?:.*?\\d){9}) # procura por 9 digitos \n"
+ "[a-z\\d ]{12,} # tem que ter 12 digitos ou mais entre `a` e `z` numeros e espaços\n\n"
+ "$ # fim\n";
final String string = "aeioa123rasdaer12311412s\n"
+ "a 1 2 3 4 a f e 4 6 9 a 1 2\n"
+ "falha Por Que so tem Letras e espaço\n"
+ "012345679PassaPorqueTemNumeros\n"
+ "444Pass4 3P0r que T3m L3tr4as numeros e espaco \n"
+ "012345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}