use strict;
my $str = '[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]
[ct_col col="4"][test2 text="Test Text" email="example@gmail.com" textarea="Test Text" editor="Test Text" select="test2" radio="test2" checkbox="test2" radio_image="test2" checkbox_image="test2" radio_button="test2" checkbox_button="test1,test3" text_multi="test 1,test 2" number="50" range="50" dimension="20,px" Icon="fa fa-cogs" color="#ff00ff" rgba="rgba(25,56,58,0.65)" font_style="[object Object]" text_align="left" image="[]" font="[]"][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test][/ct_col]
[ct_col col="4"][test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test2 data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test2] ssd[/test][/ct_col]
[ct_col col="4"][test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsd [test data="Test Text" color="#ffffff" multi="test 1,test 2"]dsdssd[/test] ssd[/test][/ct_col]';
my $regex = qr/(\[(test|test2)(?![\w-]).*?\](?!["])(.*?\[\/(\2)\])?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}