$re = '/<p>(?:[^](?!<\/p>))*<h[1-6]>/i';
$str = '<p> ... <h1>
<p> ... </p><h1>
<P> Hello
<h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);