const regex = /^([\u00C0-\u1FFF\u2C00-\uD7FF]+(?:[^a-z\u00C0-\u1FFF\u2C00-\uD7FF]+[\u00C0-\u1FFF\u2C00-\uD7FF]+)*) [a-z]+[^\u00C0-\u1FFF\u2C00-\uD7FF]*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\u00C0-\\u1FFF\\u2C00-\\uD7FF]+(?:[^a-z\\u00C0-\\u1FFF\\u2C00-\\uD7FF]+[\\u00C0-\\u1FFF\\u2C00-\\uD7FF]+)*) [a-z]+[^\\u00C0-\\u1FFF\\u2C00-\\uD7FF]*$', 'i')
const str = `Шедевры православной музыки - 20 золотых православных песен`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}