package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\+)?[^\d]+`)
var str = `41815422`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}