use strict;
my $str = '41815422';
my $regex = qr/(^\+)?[^\d]+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";