#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((https?:\/\/)?((www|\w\w)\.)?linkedin\.com\/)((([\w]{2,3})?)|([^\/]+\/(([\w|\d-&#?=])+\/?){1,}))$"
Local $sString = "in.linkedin.com/pub/first-second/05/25/86" & @CRLF & _
"in.linkedin.com/pub/first-second/1/638/7a1" & @CRLF & _
"http://uk.linkedin.com/pub/first-second/1/1b3/b45/" & @CRLF & _
"http://in.linkedin.com/pub/first-second/hfk/uty" & @CRLF & _
"http://www.linkedin.com/in/aname/" & @CRLF & _
"http://linkedin.com/in/name" & @CRLF & _
"http://in.linkedin.com/in/name" & @CRLF & _
"http://in.linkedin.com/in/name/" & @CRLF & _
"in.linkedin.com/in/name/" & @CRLF & _
"https://www.linkedin.com/profile/view?id=AAIAABgM9d4ymiX9Dy4yXkQq9i1W01JsbMXp8lM&trk=nav_responsive_tab_profile" & @CRLF & _
"www.myweb.com?id=12&value=val" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")