re = /((https?:\/\/)?((www|\w\w)\.)?linkedin\.com\/)((([\w]{2,3})?)|([^\/]+\/(([\w|\d-&#?=])+\/?){1,}))$/m
str = 'in.linkedin.com/pub/first-second/05/25/86
in.linkedin.com/pub/first-second/1/638/7a1
http://uk.linkedin.com/pub/first-second/1/1b3/b45/
http://in.linkedin.com/pub/first-second/hfk/uty
http://www.linkedin.com/in/aname/
http://linkedin.com/in/name
http://in.linkedin.com/in/name
http://in.linkedin.com/in/name/
in.linkedin.com/in/name/
https://www.linkedin.com/profile/view?id=AAIAABgM9d4ymiX9Dy4yXkQq9i1W01JsbMXp8lM&trk=nav_responsive_tab_profile
www.myweb.com?id=12&value=val
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end