#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)album_release_date: \"(.*?)\""
Local $sString = "" & @CRLF & _
"var TralbumData = {" & @CRLF & _
"" & @CRLF & _
" current: {" & @CRLF & _
" "upc":null,"title":"BLACK&WHITE MEDICINE","purchase_title":null," & @CRLF & _
" "download_desc_id":null,"minimum_price":0.0,"set_price":7.0,"mod_date":"17 Jun 2018 11:47:50 GMT"" & @CRLF & _
" }," & @CRLF & _
" album_is_preorder: null," & @CRLF & _
" album_release_date: "17 Jun 2018 00:00:00 GMT"," & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")