import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "album_release_date: \\\"(.*?)\\\"";
final String string = "\n"
+ "var TralbumData = {\n\n"
+ " current: {\n"
+ " \"upc\":null,\"title\":\"BLACK&WHITE MEDICINE\",\"purchase_title\":null,\n"
+ " \"download_desc_id\":null,\"minimum_price\":0.0,\"set_price\":7.0,\"mod_date\":\"17 Jun 2018 11:47:50 GMT\"\n"
+ " },\n"
+ " album_is_preorder: null,\n"
+ " album_release_date: \"17 Jun 2018 00:00:00 GMT\",\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}