package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(channel\/|user\/)(?P<unslash>[\w_-]+)|\/(channel\/|user\/)(?P<slash>[\w_-]+)\/`)
var str = `http://www.youtube.com/user/TheJuicyJVEVO
https://www.youtube.com/channel/UC4SusBgD3b1G5cCh_gjA81g
http://www.youtube.com/user/fabrikaband?gl=RU&hl=ru
https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/featured
https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/videos?a=b&b=c
https://www.youtube.com/duranduran
https://www.youtube.com/r3hab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}