import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:[^,()]*|(?:\\([^)]*\\)))*$).*$";
final String string = "foobar\n"
+ "foo,bar\n"
+ "foo(xx,yy)bar\n"
+ "foo(xx,yy),baz\n"
+ "foo,(xx,yy)qux\n\n"
+ "a,b,c,d{\n"
+ " a,b(c, d),e { \n"
+ "a,(b,c),d{\n"
+ "a , bwefbfrew{\n"
+ "a,:is(b,c)s ss:is(b,c)sssss{\n"
+ "wefewfew,fewf{\n"
+ "fwafaewa,(b,c){\n\n"
+ "wefwefewfee{\n"
+ "(a,b,c,d)eeeeee(few)eeee{\n"
+ "ewfeweew{\n"
+ "wafewaf(s)ewfewew(){\n"
+ "afewfe(s,)wfew{\n"
+ "fef ewee{\n"
+ "a sefe few:has(few,few){\n"
+ "aafew:has(few,fewf,few){\n\n"
+ "span:is(p, b, a),da{\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}