$re = '/ ?[^*]me/';
$str = 'she saw me now
she saw *me now
she saw +me now ';
$subst = " foo";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;