// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)\{(.*)\}").unwrap();
let string = "someOtherMessage{
class = \"someClass\";
sampleMessage{
someValue{
someText{
someParam = \"value\";
someSymbol = \"another_symbol\";
}; //someText
}; //someValue
}; //sampleMessage
}; //someOtherMessage
someOtherMessage2{
class = \"someClass2\";
sampleMessage2{
someValue2{
someText2{
someParam = \"value2\";
someSymbol = \"another_symbol2\";
}; //someText2
}; //someValue2
}; //sampleMessage2
}; //someOtherMessage2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}