const regex = /(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+[^a-z0-9]+|[^a-z0-9\']+\\s+|[\\s&\\\/]|^)+(\\w)', 'g')
const str = `title case split
world's title
fish&chips
(capitalize)`;
const subst = `$1[$2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);