#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{(?<token>{?[^}]+}?)}"
Local $sString = "{tokenTwo}_{tokenThree} or {tokenOne}{tokenTwo}" & @CRLF & _
"Some text {{someToken}} other text" & @CRLF & _
"Some text {someToken} other text" & @CRLF & _
"Some text {{someOtherToken}} other text {tokenTwo} more {tokenThree} text {lastToken}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")