using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?<token>{?[^}]+}?)}";
string input = @"{tokenTwo}_{tokenThree} or {tokenOne}{tokenTwo}
Some text {{someToken}} other text
Some text {someToken} other text
Some text {{someOtherToken}} other text {tokenTwo} more {tokenThree} text {lastToken}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}