import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "$(?<!\\.(?:ico|gif|jpg|png|css|rss|xml|htm|pdf|zip|txt|ttf)$|(?:js|gz)$|(?:html|woff)$)";
final String string = "http://gioplet/articles\n"
+ "http://gioplet/img/logo.png\n"
+ "http://gioplet/index.php\n"
+ "http://gioplet/css/main.css\n"
+ "http://gioplet/.css/main\n"
+ "http://gioplet/.png/main\n"
+ "http://gioplet/main/index.html\n"
+ "http://gioplet/js/main.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}