package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.*?\](?:(?:,|\s+and\s+)\s*\[.*?\](?:\s+and\s+\[.*?\])*)*`)
var str = `[Name]
[Name 1], [Name 2]
[Name 1] and [Name 2]
[Name 1], [Name 2] and [Name 3]
[Name 1], [Name 2] and [Name 3], [Role]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}