using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}";
string input = @"CONTEXT_MANAGER_ALARM_WAKEUP_2151111113123122132134535342524364542142";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}