package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+)(?:')`)
var str = `=if(D3<>"",if(iferror(regexmatch(D3,"([0-9]+)(?:')"),false)=true,REGEXEXTRACT(D3,"([0-9]+)(?:')")*12+REGEXEXTRACT(D3,"([0-9]+)(?:"&char(34)&")"),D3*12),"")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}