import Foundation
let pattern = ##"""
^ # begin
\s*# some empty spaces
(?:
\+? # + symbol
\d{1,2} # country code
\s*
(?(?=\)) # if followed by parens
| # then dash not allowed
-? # else optional dash
)
)? #prefix like +380
\s*
(?:
(?P<leftparen>\()? # optional left paren
\s*
0\d\d
\s*
(?(leftparen)\)|) # right paren if and only if left paren
)? # operator code, starting with 0, optinally in parentheses
(?(?<=\)) # if preceded by parens
\s*| # then dash not allowed
\s*-?\s* # else optional dash
)
(?:
\d |
(?<=
\d
)
(?(sep)
(?P=sep)|
(?P<sep>[\-\/\ ])
)
(?=
\d
)
){5,13}
\s*# some empty spaces
$ # end
#\d\d\d (?P<separator>-?) \d\d (?P=separator) \d\d $
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
SHOULD MATCH:
5344654
5344654
534-46-54
17189280121
+19173010176
(095)789-58-75
(095) 789-58-75
0957895875
917 229 2897
+38 (095) 5344654
53-475-34
555-1-333
1-333-484
888-333-4
(094)999-22-44
38-095-432-43-34
095-432-43-34
123456
53465
SHOULD NOT MATCH:
1
-1234
38-(095)-432-43-34
534-46/54
(094)999/22-44
1234--567
(345)5345654
(0955344654
095)5345654
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)