import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[-x+]\\h*may(?:15)?|may(?:15)?\\h*[-x+])(*SKIP)(*F)|may(?:15)?";
final String string = "x May15 > WRONG\n"
+ "- May15 > WRONG\n"
+ "+ May15 > WRONG\n"
+ "xMay15 > WRONG\n"
+ "-May15 > WRONG\n"
+ "+May15 > WRONG\n"
+ "May15 > TRUE\n"
+ "May15, > TRUE\n"
+ "May15 + > FALSE";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}