re = /\w+(?:[- ]\w+)*/
str = 'Some Words - Other Words (More Words) Dash-Binded-Word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end