package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`rain\s*(.*)`)
var str = `The rain in Spain falls mainly in the plain`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}