re = /(.*)\((.*)\) (.*)/
str = 'Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59'
subst = '$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result