#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0)(?:9\d\d|\d{4,5}|[1-7]\d{5}|8[0-5]\d{4}|86[0-3]\d{3}|864000)$"
Local $sString = "0" & @CRLF & _
"10" & @CRLF & _
"899" & @CRLF & _
"900" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"99999" & @CRLF & _
"799999" & @CRLF & _
"800000" & @CRLF & _
"859999" & @CRLF & _
"860000" & @CRLF & _
"863999" & @CRLF & _
"864000" & @CRLF & _
"864001" & @CRLF & _
"999999" & @CRLF & _
"1000000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")