using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0)(?:9\d\d|\d{4,5}|[1-7]\d{5}|8[0-5]\d{4}|86[0-3]\d{3}|864000)$";
string input = @"0
10
899
900
1000
1001
99999
799999
800000
859999
860000
863999
864000
864001
999999
1000000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}