use strict;
my $str = '0
10
899
900
1000
1001
99999
799999
800000
859999
860000
863999
864000
864001
999999
1000000
';
my $regex = qr/^(?!0)(?:9\d\d|\d{4,5}|[1-7]\d{5}|8[0-5]\d{4}|86[0-3]\d{3}|864000)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}