package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^(("[a-zA-Z0-9\-\_\@,\.:\$*]+"|[0-9]+)=>("(.*)"|[0-9]+),?)+$`)
var str = `"o"=>"1",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}