re = /(\<h3 id=\"title\" class=\"mb-0 mt-0\"\>)(\<\?php echo L10n::icon\(')(.*?)('\); \?>)(\<\?php echo L10n::message\('label.)(.*?)(', )(L10n::label\()(.*?)(\); \?>)(\<\/h3>)/m
str = '<h3 id="title" class="mb-0 mt-0"><?php echo L10n::icon(\'camera\'); ?><?php echo L10n::message(\'label.add\', L10n::label(\'camera\')); ?></h3>
<h3 id="title" class="mb-0 mt-0"><?php echo L10n::icon(\'bookmark\'); ?><?php echo L10n::message(\'label.add\', L10n::label(\'bookmark\')); ?></h3>
<h3 id="title" class="mb-0 mt-0"><?php echo L10n::icon(\'dashboard\'); ?><?php echo L10n::message(\'label.add\', L10n::label(\'dashboard\')); ?></h3>
<h3 id="title" class="mb-0 mt-0"><?php echo L10n::icon(\'dashboard\'); ?><?php echo L10n::message(\'label.edit\', L10n::label(\'dashboard\')); ?></h3>'
subst = '$1$2$3$4<?php echo L10n::label($7)$8$9'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result