#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^.*\/"
Local $sString = "/season/path/12345/1/168702"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)