use strict;
my $str = '/season/path/12345/1/168702';
my $regex = qr/^.*\//p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";