const regex = /[A-Z][a-z]{2} \d{1,2}, 201[1-4]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z][a-z]{2} \\d{1,2}, 201[1-4]', '')
const str = `Jan 5, 2011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}