$re = '/embed\/([\w+\-+]+)[\"\?]/';
$str = '<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/b8-dyNY-j_123-o0xM" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/uMs_Rq4ideA" frameborder="0" allowfullscreen></iframe>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);