$re = '/(?<![,\.\ ])(?=[,\.]+)|(?<=[,\.])(?![,\.\ ])|(?<=[,\.])\ +(?![,\.\ ])|(?<![,\.\ ])\ +(?=[,\.][,\.\ ]+)|(?<![,\.\ ])\ +(?![,\.\ ])/';
$str = 'This, I think,., کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think, . ,کباب MAKES , some sense
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;