# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"export\s+async\s+function\s+generateMetadata\s*\(\s*\{[\s\S]*?\}\s*\):\s*Promise<Metadata>\s*{\s*const\s*\{\s*t\s*\}\s*=\s*await\s*translationServer\s*\(\s*locale\s*,\s*'projectTitles'\s*\);\s*return\s*\{\s*title\s*:\s*translate\s*\}?\s*}"
test_str = ("import { Metadata } from 'next';\n\n"
"import CreateEnactment from './_components';\n"
"import { translationServer } from 'i18n';\n"
"import { hasPermissionServerSide } from 'utils';\n\n"
"const CreateEnactmentPage = async () => {\n"
" await hasPermissionServerSide({ branchRoles: ['ADMIN', 'OPERATOR'] });\n\n"
" return <CreateEnactment />;\n"
"};\n\n"
"export async function generateMetadata({ params: { locale, enactmentId } }: { params: Params }): Promise<Metadata> {\n"
" const { t } = await translationServer(locale, 'projectTitles');\n\n"
" const translate = enactmentId === 'new-enactment' ? t('newEnactment') : t('viewEnactment');\n\n"
" // to meta tag\n"
" return {\n"
" title: translate\n"
" };\n"
"}\n\n"
"export default CreateEnactmentPage;\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.