use strict;
my $str = 'Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable
Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable
Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable
Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable
Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable';
my $regex = qr/Vlan(\d+).+?(\d+\.\d+\.\d+\.\d+)\s+(\d+\.\d+\.\d+\.\d+)/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}