# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Vlan(\d+).+?(\d+\.\d+\.\d+\.\d+)\s+(\d+\.\d+\.\d+\.\d+)"
test_str = ("Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable\n"
"Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable\n"
"Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable\n"
"Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable\n"
"Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.