// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Vlan(\d+).+?(\d+\.\d+\.\d+\.\d+)\s+(\d+\.\d+\.\d+\.\d+)").unwrap();
let string = "Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable
Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable
Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable
Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable
Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}