import Foundation
let pattern = #"Vlan(\d+).+?(\d+\.\d+\.\d+\.\d+)\s+(\d+\.\d+\.\d+\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable
Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable
Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable
Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable
Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}