re = /\/my\/interesting\/path\/(?![0-9]*$)(\b[0-9A-Z]{11}\b)/m
str = 'http://myapp:8080/my/interesting/path/ABCDEF12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end