using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?!true|false))\w+\b";
string input = @"""O_1324||T_6789||EC_67889&&(IC_12345||chicken)||true&&false""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}