const regex = /\[([^\[\]]*?)\]\((\S*?)\)/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\[\\]]*?)\\]\\((\\S*?)\\)', 'gsi')
const str = `# Basic Cases
[test link](http://test.com)
[test-link@test.com](http://test.com/test-link)
[title (parenthesis)](http://www.test.com)
[relative link](/test-link/page)
[anchor reference](#reference)
[title with
linebreak](http://test.com)
# Extra Cases
[]()
[](uri:empty-title)
[[extra sq bracket](ftp://test.com)
[extra sq bracket - invalid]](https://test.com)
[extra parentheses](((())))
[link with linebreak - invalid](http:
//test.com)
# Lazy Delimiter Testing
[()][()][(][)[][]))([()[(((][(]][)([(])))[()
[((()))]()
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}