#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*sources\s*:\s*\[(.*?)\]"
Local $sString = "var player = new Clappr.Player({" & @CRLF & _
" sources: ["https://c8.videobin.co/hls/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7s,rqmgzeecwdox4infaoa,icmgzeecwdjhatedksa,.urlset/master.m3u8","https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7sicmgzeecwdjhatedksa/v.mp4","https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7srqmgzeecwdox4infaoa/v.mp4"], " & @CRLF & _
" poster: "https://c8.videobin.co/i/01/00010/m5pbbn9strm5_xt.jpg", " & @CRLF & _
" width: "100%"," & @CRLF & _
" height: "100%"," & @CRLF & _
" disableVideoTagContextMenu: true," & @CRLF & _
" maxBufferLength: 15," & @CRLF & _
" parentId: "#vplayer"" & @CRLF & _
" ,plugins: {"core": [ClapprThumbnailsPlugin,LevelSelector]}" & @CRLF & _
" ,scrubThumbnails: {" & @CRLF & _
" backdropHeight: 60," & @CRLF & _
" spotlightHeight: 60," & @CRLF & _
" thumbs: thumbs" & @CRLF & _
" },maxBufferLength: 15,levelSelectorConfig: {" & @CRLF & _
" title: 'Quality'," & @CRLF & _
" labels: {" & @CRLF & _
" 3: 'Higher'," & @CRLF & _
" 2: '1080p'," & @CRLF & _
" 1: '720p'," & @CRLF & _
" 0: '480p'," & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" });"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")