#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=_)(\d+$)"
Local $sString = "I have 104 digits" & @CRLF & _
                "" & @CRLF & _
                "This is supposed to remove digits from the suffix like 501" & @CRLF & _
                "" & @CRLF & _
                "This only works if the suffix is preceeded by an underscore, like this_420"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)