import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,2}h)[ ]*([0-9]{1,2}min):[ ]*(.*(?:\\n(?![0-9]{1,2}h).*)*)";
final String string = "1h 30min: Title \n"
+ "- Description Line 1\n"
+ "1h 30min: Title\n"
+ "- Description Line 1\n"
+ "- Description Line 2\n"
+ "- Description Line 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}